별거 없다. 플러그인 파일의 압축을 적당한 압축 프로그램을 이용해서 풀어보면 그 안에 install.rdf파일이 있다. 이 파일을 열어보면 이 플러그인을 쓰기에 적당한 버전이 적혀있다. 대충 version이라는 말이 들어가 있는 태그로 묶여 있는데, 여기서 maxversion을 2.0이나 뭐 그 이상으로 올려주면 설치된다. 물론, 수정한 상태를 저장하고, 다시 그 파일을 원래의 압축화일 형식으로 압축해줘야 한다. xpi인 경우는 zip으로 압축한 후 확장자를 xpi로 고쳐주면 되고, jar는 그냥 열리더라. 추천할만한 압축프로그램은 양병규님의 빵집이다.

단. 공식적인 업데이트가 아니라 무작정 설치하는 것이기 때문에 파이어폭스에 어떤 변고가 일어날지는 모른다. 대부분의 경우 하위 호환성이 있으므로 아마 잘 작동할 거라고 생각하지만, 작동하지 않는다고 해도 어쩔 수 없다. 이런 경우에는 직접 소스를 고쳐보든가, 직접 만들든가, 아니면 제작자의 공식적인 업데이트를 기다리는 수밖에 없다.


by snowall 2007.01.18 11:15